pip 安装模块发生 HTTPSConnectionPool 错误

Python 2016-05-06 13:37 暂无评论

系统:OS X 10.11.2

pip 安装 pycurl 的时候报错 HTTPSConnectionPool SSL不可信,导致安装失败。

  1. 更换镜像源
    目前国内:
    V2EX:http://pypi.v2ex.com/
    豆瓣:http://pypi.douban.com/
    华中理工大学:http://pypi.hustunique.com/
    山东理工大学:http://pypi.sdutlinux.org/
    中国科学技术大学:http://pypi.mirrors.ustc.edu.cn/

手动指定源:pip install -i http://pypi.douban.com/simple pycurl 注意:不要忘记后面还有 simple 这个目录,否则指定安装时会失败。:

  1. 不更换源
    如果不更换源,直接用 pip install --index-url=http://pypi.python.org/simple/ --trusted-host pypi.python.org pycurl 设置为可信即可
暂无评论